Oleh: hendrainfo | Desember 15, 2012

Membuat Ip Dynamic menjadi static menggunakan no-ip.com via mikrotik

Setelah menjelajah ke sana kemari mencari script Dynamic DNS menggunakan no-ip.com, akhirnya ketemu juga.

Jika router mikrotik mendapat IP Address Public Dynamic maka,
berikut ini adalah script untuk update ip via no-ip.com
pertama-tama, tentu saja daftar di
(daptar nya kalau mau lewat referal gw, tinggal klik link tersebut, kalau gak berkenan ya gpp)

registrasi dan add host di no-ip.com
1. registrasi seperti biasa, isi first name, last name, email, username, password, dll. (yang di bold harap diperhatikan)
2. setelah registrasi selesai, login dengan username dan password.
3. Pilih Hosts/Redirects, lanjut dengan pilih Add Host
4. Isikan nama hostname dan pilih domain nya. (lagi-lagi yang di bold harap diperhatikan)
5. IP Address diisikan : 127.0.0.1
6. Setelah itu klik Create Host pada bagian bawah form.
7. Pembuatan hostname selesai. Tunggu satu menit untuk diupdate. Sementara itu kita buat scriptnya..

masuk winbox, pilih system–schedule–add

Name: sch-ddns-NoIP
Start Date: Jan/01/1970
Start Time: startup
Interval : 00:05:00 # tiap lima menit

Isikan on-event script berikut:

ubah yang garis bawah dengan username, password, wanInt, dan hostname lengkap dengan domainnya di no-ip (mis. fmi.zapto.org)
username, password, dan hostname terdapat pada bagian yang di bold di tutorial registrasi di atas.

# Set needed variables
:global username "your-username"
:global password "your-password"
:global hostname "your-hostname"
:global wanInt "your-Interface"
:global noipForce
:global previousIP2

# print some debug info
#:log info ("DDNS: username = $username")
#:log info ("DDNS: password = $password")
:log info ("DDNS: hostname = $hostname")
:log info ("DDNS: previousIP = $previousIP2")

# Grab the current IP address on that interface.
:global ddnsip [/ip address get [/ip address find interface="$wanInt"] address]
:global currentIP [:pick $ddnsip 0 [:find $ddnsip "/"]]

#:log info ("DDNS: ddnsip = $ddnsip")
:log info ("DDNS: currentIP = $currentIP")

# Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by No-IP!
#:set noipForce true

# Determine if no-ip update is needed
# more no-ip updater request details available at http://www.no-ip.com/integrate/request/
:if (($currentIP != $previousIP2) || ($noipForce = true)) do={
    :set noipForce false
    :set previousIP2 $currentIP
    :log info ("DDNS: No-IP update needed")
    :log info ("DDNS: Start of Fetch")
global tmp [/tool fetch mode=http port=80 address=dynupdate.no-ip.com host=dynupdate.no-ip.com src-path="/nic/update?hostname=$hostname&myip=$currentIP" user=$username password=$password dst-path="/noip2.txt"]
    :log info ("DDNS: End of Fetch")
    :global result [/file get noip2.txt contents]
    :log info ("DDNS: No-IP Update Result: $result")
    :put ("No-IP Update Result: $result")
# Update HE.net Tunnel
#   :execute script=HE-NET
} else={
    :log info ("DDNS: No No-IP update needed")
}

Responses

  1. Mantap pak,….

    Kalau script buat linux CentOS gimana kira-kira pak..

    Mohon bantuannya,….

  2. ora lengkap…anu mumet…

  3. tutornya dapat copy dimana nih gan??? kgk lengkap… garis bawahnya mana??? trus wanInt itu apa gan??? mohon dikasih keterangan

  4. Terima kasih atas informasinya kang

  5. Top markotop…… @multisolusi.co.id

  6. muantab tutornya…terima kasih banyak, smoga tambah sukses

  7. Mas mau tanya nih… di bagian “IP Address diisikan : 127.0.0.1” ip 127.0.0.1 bisa di tentuin sendiri tidak dan ip ini fungsinya apa? ato dengan mengisikan ip 127.0.0.1 ip kita yg dynamin dr telkom menjadi ini???
    maaf panjang… Terima kasih


Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

Kategori

%d blogger menyukai ini: